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1 RockWin

Overview

The File Menu

The Input Menu

The Utilities Menu

The Help Menu

References

About RockWin

Help File Updated: Saturday, March 25, 2023.

1.1 Overview

The Rockwin package was developed to help mining and geotechnical engineering
students gain insight to some of the basic concepts of 2D and 3D stress and strain
analysis, failure criteria, interpretation of lab results and other aspects of
geomechanics. 
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2 The File Menu

Description:

Use the File menu option to access various file management operations such as:

Creating New Files

Opening Existing Files

Saving Files

Saving Files under Different Names (Save As)

Setting up the Printer

Printing Files

Print Preview

Browsing Text Files

Exiting the Program

2.1 Creating New Files

Description:

Use the New option to erase the existing dataset (if any) from memory and create a
new (blank) dataset.  All related entries are set to their initial values. 

Notes:

· The program will prompt you whether to save the current file to disk.

2.2 Opening Existing Files

Description:

Use the open option to load a file (dataset) from the disk into program memory.

To use Open:

· Select the Open option from the File menu.  The program displays a listing of
the available files in the current data directory.

· Optionally, select a different drive or directory using the mouse or the cursor
control keys.

· Select or enter a filename.  
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Notes:

· If the file extension is omitted, the default extension will be appended. 
· If the current dataset is not saved, the program will prompt whether to save

changes or not before discarding the current dataset.

2.3 Saving Files

Description:

Use the Save option to save an existing file (dataset) to the drive or directory from
which it was originally loaded.  Any changes that were made since the last time the file
was saved will be saved on the disk.  The filename stays the same and the file remains
in memory.

To use Save:

Select the Save option from the File menu.

Notes:

· If the file has never been saved using the Save As option, choosing Save
automatically displays the Save As dialogue box, which prompts for a filename
before saving it.

2.4 Saving Files under Different Names  (Save As)

Description:

Use the Save As option to save a file and give it a new name.

To use Save As:

· Select the Save As option from the File menu.  The program displays a listing of
the available files in the current data directory.

· Optionally, select a different drive or directory. 
· Select or enter a filename.

Notes:

· If the file exists, the program will prompt whether to overwrite the existing file.
· Use Save for a faster save operation.
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2.5 Setting Up the Printer

Description:

Use this option to select the Printer to use for printing output and graphics. This printer
becomes the Windows default printer. 

To use this option:

Select the Printer from the drop-down list and click on OK. 

2.6 Printing Files

Description:

Use the Print option to print the current dataset (file) from program memory to the
default windows printer.  The default printer may be set using the Setting Up the Printer
menu option. 

Notes:

· The file is send directly to the printer, without preview. Use the Print Preview
option to preview the file and then send it to the printer. 

2.7 Print Preview

Description:

The user may navigate through the Print Preview Window by using the vertical scroll
bar. 

The text in the window can be send directly to the printer, or it can be copied to the
Windows clipboard for use in other applications.

Notes:

· This operation does not send any control characters to the printer. All output is
ASCII text. The text prints in "Courier" or "Courier New" font in size 9. If these
fonts are not available to the printer, then printed text will appear in the default
printer font.

· Each printed page is formatted with preset margins as follows:
ό left margin = 1 inch
ό top margin = 1 inch
ό bottom margin = 1 inch
ό right margin = variable
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2.8 Browsing Text Files

Description:

Use the browse option to view a text (ASCII) file in a specified directory.  No editing is
allowed during browsing.

Use the pattern field to specify a file pattern (i.e. *.txt). The file window will be reset to
conform to the specified pattern. The default pattern is *.ALP. More than one patterns
can be applied using “;” as delimiter (e.g. *.txt;*.dxf).

Use the Set Font command button to specify the type and size of font for the displayed
text. These settings are saved in the RockWin.INI file.

Use the cursor control keys to move within the browse window.

2.9 Exiting the Program

Description:

Use the Exit option when ready to exit this program and return to the original
environment. The program will prompt you to save the current file to disk, if not already
saved.
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3 The Input Menu

Description:

Use the Edit menu option to access various parameter input/edit forms such as:

Project Description

Project Input Parameters (this includes a number of options categorized thematically)

3.1 Project Description

Description:

This is an arbitrary 300 character description of the model being generated.  It is a
recommended to make this a fairly detailed description of the specifics of the input file.
This text may be a single line of characters or may contain "carriage return characters".

The user can also set the type of units that will be used in the current project. The
program is designed to use two different sets of units:

· English (i.e. ft, lbs, etc)
· Metric (i.e. m, kN, etc)

Note that calculations performed in many of the forms in this program are unitless, i.e.
they work the same for any unit. 

3.2 Project Input Parameters

Options:

Stress Analysis

Failure Criteria

Elasticity in 2D

Strain Analysis

Coordinate Transformation

Laboratory Evaluation

Roof Bolting
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3.2.1 Stress Analysis

2D

3D

Circular Openings

Room and Pillar Mining

Point Load on Surface

Distributed Load on Surface

3.2.1.1 2D

This tool calculates the orientation and magnitude of the principle stresses from the two-
dimensional stress state provided. The normal and shear stress on any plane,
measured from the maximum principle stress direction, is also calculated. A diagram
showing the orientation of the input data is shown next to the input data box in the image
below. Click "View Orientation" to show a diagram showing the orientation of the
principle stresses below.
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Input numbers are in black. Results are shown in red. 

To view the Mohr's circle for the inputted stress state, check the box next to "Mohr's
Circle" and a graph will extend to the right of the data entry area. The plane stress state
is shown on the graph in pink.

3.2.1.2 3D

This tool calculates the stress invariants and the magnitude of the principle stresses
from the three-dimensional stress state provided. 

To calculate the deviatoric stress tensor or stresses at a given plane, check the box next
to the respective option and the additional tabs will be made available.
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Additional tabs not available with check boxes unchecked.
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Additional tabs become available after check boxes are checked.

Input numbers are in black. Results are shown in red.

The deviatoric stress invariants are calculated by providing the deviatoric stress tensor.
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The stresses on any plane are calculated by providing the unit vector of the desired
plane. The normal of the unit vector, stress vector, and normal and shear components of
the stress vector are calculated.
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3.2.1.3 Circular Openings

The stress around circular openings is calculated by providing the stress state, radius of
the opening, and angle from the horizontal to the stress state desired. 

In the calculations tab, a radial distance greater than the radius of the opening can be
entered to calculate the radial, tangential, and shear stress at that point. The stress
ratios are also calculated.
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Input numbers are in black. Results are shown in red.

If the box next to "Graph" is checked, then the plot of the stress distribution around the
opening at the location specified will open as soon as the stresses and radius are
entered. To open this if it does not open automatically, check the box next to "Graph"
and click "Plot Stresses". 

To plot to 3 times the radius, check the box next to "Plot to 3R". Otherwise the graph will
plot to 5 times the radius. 
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The radial, tangential, and shear stresses are plotted for the stress state and orientation
provided. The x-axis is the distance from the center of the opening, expressed in radii.
The y-axis is the stress ratio, and is unitless.



The Input Menu 21

© 2023 Prof. Z. Agioutantis

The graph can also be shown by clicking on the "Graph" tab.

The solutions and graphs are generated based on the formulation by Kirsch. The Kirsch
equations are a set of closed-form solutions, derived from the theory of elasticity, used
to calculate the stresses and displacements around a circular excavation in an infinite
medium. 
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(Erik Eberhardt – UBC Geological Engineering, ISRM Edition)

3.2.1.4 Room and Pillar Mining

The axial stress and extraction ratio of a room and pillar design are calculated by
inputting vertical stress, pillar width, pillar length, and opening width.

The average axial stress on the pillars and extraction percentage are calculated.
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Input numbers are shown in black. Results are shown in red.

Units should be uniform, feet, lbs/sq.ft, etc.

3.2.1.5 Point, Line and Strip Load on Surface

This tool calculates the additional stress on a point underground due to a vertical point
load on the surface. Enter the point load and horizontal and vertical distance of the point
to calculate. The load can also be entered as a line load or a strip load by selecting the
appropriate radio button option.
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Input numbers in black. Results are shown in red.

Hovering the mouse over different points in the blue vertical section shown calculates the
additional pressure at each of the points specified.

The French mathematician Boussinesq developed an expression for the stress
distribution under a point load on the surface of a homogeneous, isotropic linearly
elastic half space (i.e.,  "soil surface"). The soil is not really homogeneous and isotropic,
it is usually layered. It is not linearly elastic, instead its elasticity generally increases with
depth, becoming stiffer as the overburden stress increases. Boussinesq is very useful,
however, because it represents the greatest stress that can be developed for a given
loading condition.

The change in total stress at a depth z and radius r from the point of application of a
Point Load Q is given by
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Westergaard produced a similar relationship for the case in which the soil is
homogeneous but anisotropic, in which zero lateral deformation is allowed. This
represents the other extreme from the Boussinesq solution. Real soil behavior generally
falls between these two solutions. The Boussinesq solution is more commonly used
because it yields higher vertical stress values; the Westergaard solution is primarily
used as a comparison value. The Westergaard relationship is:

 

Comparison between the two formulations:
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3.2.1.6 Distributed Load on Surface

The additional pressure on a point underground from a distributed load on the surface is
calculated using this tool. 
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Input numbers are in black. Results are shown in red.

Click on Details to get the following graph and different analysis options. 
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The stresses and deformations generated in an elastic half space by a uniform, normal,
surface pressure applied over a rectangular area, can be found by subdividing the
rectangular
area into sufficiently small blocks and treating the stress applied by each block as a
point load. Theoretically exact solutions may be obtained by integration:

where p is the uniform vertical pressure applied over a rectangular area of dimensions A
by B defined on a horizontal plane surface, and z is the depth beneath one corner to the
point at which the vertical normal stress is to be calculated. Two dimensionless factors
are defined as m = A/z and n = B/z. The entire right hand side of the first equation above
can be considered an influence factor (Ir). 

Values for the influence factor were calculated by Newmark (1935) and have been
presented in tabular or graphical form by Fadum (1948), Spangler (1951), Taylor
(1948), and others. Because of their usefulness, the influence factors have been
tabulated below:

Influence Factors for the Vertical Compressive Stress Beneath One Corner of a
Uniformly Loaded RectangularArea at the Surface
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3.2.2 Failure Criteria

Coulomb in Material

Coulomb in Material with Joint

Coulomb in Material with Bolted Joint

Coulomb in Bolted Rock Slope

Bieniawski

Hoek - Brown

Von Mises

Circular Openings

3.2.2.1 Coulomb in Material

The Coulomb failure criterion of a material are calculated using this tool. To calculate,
enter the stress state and two of the three provided material properties. Select the dot
next to the material property that will not be provided and enter values for the two other
material properties. The magnitude and orientation of the principle stresses are
calculated for the stress state. The failure state is determined. If the material fails, then
the failure angle and shear stress at failure are calculated. 

To display no graph, select the dot next to "No Graph".
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Input numbers are shown in black. Results are shown in red.

To display the Mohr's circle and failure criteria for the stress state, select the dot next to
"Mohr's Circle".
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Material failed

Material did not fail

To display the σ1-σ2 plot and failure criterion for the stress state, select the dot next to
"s1-s2 Plot".
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Material failed

Material did not fail

The pore pressure of a material can also be entered to determine if the material fails
due to pore pressure. Check the box next to pore pressure and enter the value for pore
pressure. The failure angle is calculated for pore pressure failure.
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Material failed due to pore pressure

3.2.2.2 Coulomb in Material with Joint

This tool calculates the Coulomb failure criteria for material with a pre-existing
discontinuity. The stress state of the rock, material properties, and discontinuity
parameters are entered and the failure state of the material is determined. The material
failure due to the discontinuity and material itself are determined. The angle to the
maximum principle stress is calculated.

To display no graph, select the dot next to "No Graph".
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Input numbers are shown in black. Results are shown in red. This option allows for 2 sets
of parameters to be analyzed at the same time by selecting "Set 1" or "Set 2". 

To display Mohr's circle and failure criteria for the stress state, select the dot next to
"Mohr's Circle".
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Material failed due to discontinuity

Material did not fail

To display the σ1-β plot, select the dot next to "s1-b".
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To determine if the material or discontinuity fail due to pore pressure, check the box next
to pore pressure and enter a value for pore pressure.
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Failed at discontinuity due to pore pressure

3.2.2.3 Coulomb in Material with Bolted Joint

This tool calculates the load on a bolt holding a rock wedge. The wedge and
discontinuity parameters are entered. To calculate the safety factor for a known bolt
load, click on the "Safety Factor" tab and enter the bolt load and angle. 
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Input numbers are shown in black. Results are shown in red.

To calculate the load required of a bolt to achieve a specified safety factor, click on the
"Load" tab and enter the wedge safety factor.
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If values are entered that cause the bolt tensioning to exceed the horizontal weight
component, a message will display as shown below.
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If the slope is stable without a bolt, a message will display as shown below.
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3.2.2.4 Coulomb in Bolted Rock Slope

Option is not ready yet.

3.2.2.5 Bieniawski

The Bieniawski failure criterion are determined using this tool. Enter the stress state and
Bieniawski material properties to calculate. The magnitude and orientation of the
principle stresses are calculated and the failure state is determined.
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Input numbers are shown in black. Results are shown in red.

Select the box next to "Graph" to display a graph.
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Material failed

Material did not fail

Coefficients for Bieniawski Criterion (Bieniawski, 1984)
Rock Type A B
Norite 5.0 0.80
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Quartzite 4.5 0.78
Sandstone 4.0 0.75
Siltstone 3.0 0.70
Mudstone 3.0 0.70

The Bieniawski criterion is given by the equation below.

3.2.2.6 Hoek - Brown

The Hoek-Brown failure criteria are determined using this tool. Enter the stress state
and select the type of criterion to use. 

For intact rock criterion, select the dot next to "Intact Rock". Enter the intact UCS
(uniaxial compressive stress state), and Hoek-Brown parameter m. The failure state is
then determined and shown below.
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Input numbers are shown in black. Results are shown in red.
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For the generalized criterion, select the dot next to "Generalized Criterion". Enter the
UCS for intact rock, and parameters mb, s, and a. 
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The Hoek-Brown criterion for intact rock is given by the equation below.

The table below lists values for parameter m of the Hoek-Brown intact rock criterion
(Hoek, 2007).
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The Hoek-Brown criterion for the rock mass (or generalized criterion) is given by the
equation below.
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3.2.2.7 Von Mises

The von Mises failure criterion is determined using this tool. The stress state and tensile
strength are entered and the failure state is determined. The Von Mises stress is
calculated for the given state.

Input numbers in black. Results are shown in red.

To display a graph, select the box next to "Graph".
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Material did not

Material failed

The equation for the von Mises Stress or equivalent stress is given below.
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3.2.2.8 Circular Openings

This tool illustrates the stresses around a circular
opening at a specified radial distance. The stress state
and dimensions are entered and a visual displaying the
stress around the opening is displayed.

Input numbers are shown in black.
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The principle stress orientation is shown with the black
lines. Areas of tension and compression are
highlighted.

sy corresponds to vertical far field stress and sx
corresponds to horizontal far field stress (far field
stresses are the insitu stresses before the opening was
created. 

3.2.3 Elasticity in 2D

The user can calculate the strain based on stress values and the stress based on strain
values for the two-dimensional plane stress and plain strain analyses for elastic
materials.

To calculate stress state, click on the "Calculate Stress State" tab and enter the strain
state and material constants. Select whether the solution should be based on the
assumption of plane stress or plane strain by clicking on the dot next to the respective
option.

Input numbers are shown in black. Results are shown in red.
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To calculate strain state, click on the "Calculate Strain State" tab and enter the stress
state and material constants. Select whether the solution should be based on the
assumption of plane stress or plane strain by clicking on the dot next to the respective
option.
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3.2.4 Strain Analysis

The principle strains magnitude and orientation is calculated using this tool. Input data
from strain gauges is entered. The two-dimensional strain tensor is calculated with the
principle strains. 

The strain state at a given plane can also be calculated by entering a value for the angle
of the plane.
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Input numbers are shown in black. Results are shown in red.

3.2.5 Coordinate Transformation

Coordinate transformation can be facilitated using this tool. Select whether a tensor or
vector is needed and enter the data to get the new coordinates.
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Input numbers are shown in black. Results are shown in red.

Note: The transformation matrix should have a norm = 1.

Example of cosine matrix is shown below:
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3.2.6 Evaluation of Uniaxial Testing Results

This form helps evaluate data collected during uniaxial testing of rocks. To enter data in
the table, click on one of the cells in a yellow highlighted column. Enter the value for the
cell in the pop-up window and press Ok.
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Input numbers are shown in black. Results are shown in red.

To display a stress-strain plot of the data, select the box next to "Graph".
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3.2.7 Roof Bolting

This tool assists in determining appropriate roof bolting densities.

To determine the roof bolting density necessary for a given design select the "Roof
Bolting Density" tab and enter the bolt, rock, and design parameters. The bolt load,
stress, and bolt density is calculated.
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Input numbers are shown in black. Results are shown in red.

To determine the tensile strength of the anchor, select the "Tensile Strength of Anchor"
tab and enter the bolt, rock, and design parameters. The load at the anchor interfaces
and bolt load are calculated.
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4 The Utilities Menu

Settings

Options

Unit Conversions

File Conversion (not available at this time)

Clear History Window
This option clears the history (activity) window.

Close/Restore History Window
This option closes or restores the history (activity) window according to the current
window status.

Copy History Window
This option copies the contents of the history window to the clipboard. You can then
paste them to any text handling program for further processing. 

4.1 Settings

Description:

This form is used to define a number of default parameters and settings for the
RockWin program:

Default Units:
This setting controls the default units for a new or blank project file by configuring the
Units field in the Project Description form. Upon entering and accepting project input
parameters the default setting in the Project Description form can not be changed. 
This setting is saved in the RockWin.INI file.

Default File Extension for Input Files:
This setting is the default 3-letter extension used in the Open and Save dialog boxes in
the File Menu. This setting is saved in the RockWin.INI file.

Data Path:
This setting is the default path used in the Open and Save dialog boxes in the File
Menu.  This setting is saved in the RockWin.INI file.

Show Disclaimer:
This parameter controls whether the disclaimer message will be displayed when
loading the RockWin program. This setting is saved in the RockWin.INI file.
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Maximize Main Menu Window:
This parameter controls whether the main menu window will be maximized when
loading the RockWin  program. This setting is saved in the RockWin.INI file.

Keep Recent Filelist:
This parameter controls whether the program will keep the four (4) recently accessed
data files (opened or saved) as menu items in the File Menu. This setting is saved in
the RockWin.INI file.

Reminder of Annual Updates:
This parameter controls whether the program will display a warning that a year has
elapsed since the last update of the program. The update date is internally stored and it
is not related with the install date. Annual updates ensure that any bugs that have been
discovered are fixed regularly. This setting is saved in the RockWin.INI file.

Display Command History Window:
This parameter controls whether the program will display recently executed commands
(and their resulting actions).  This setting is saved in the RockWin.INI file.

Maximum Characters in Command History Window:
This parameter sets the maximum number of characters displayed in the command
history window, before it is cleared.  This setting is enabled only if the Display
Command History Window option is enabled.  This setting is saved in the RockWin.INI
file.

History Font:
This button sets the type and size of font used in the command history window. This
setting is enabled only if the Display Command History Window option is enabled. 
This setting is saved in the RockWin.INI file.

Enable Toolbar: 
This settings controls whether the program will display a toolbar under the main menu
options or not. The toolbar is not editable. This setting is saved in the RockWin.INI file.

Short Names in Filelist:
This parameter controls whether the program will display the filenames in the recently
accessed list in a short or long format (i.e. including the whole path).  This setting is
saved in the RockWin.INI file.

Load Last Input File:
When this setting is enabled, the program will automatically load the most recently
saved datafile (i.e. the top in the recently accessed files). This setting is saved in the
RockWin.INI file.

Copy Example Files:
When this setting is enabled, the program will automatically copy all example files from
the "Program Files" directory to the user home directory (i.e. MyDocuments/MyTUC).
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This procedure runs upon every program invocation unless disabled. The modified files
will not be overridden, but missing files will be replaced. This setting is saved in the
RockWin.INI file.

External ASCII Viewer:
The user can set the application name of an external ASCII viewer for viewing reports
and other ASCII files generated by the program.  The default viewer in NOTEPAD.EXE
supplied with the windows operating system.  Note that prior to Windows2000,
NOTEPAD.EXE could only edit / display files up to 64K.  This setting is saved in the
RockWin.INI file.

4.1.1 RockWin.INI

Description:

This file is automatically created by the RockWin program the first time it is executed. It
should reside in the home directory of the RockWin program, i.e. \RockWin.  It contains
the following entries (the sequence and parameter values may be different in the actual
file):

[Settings]
DefaultUnits=0
DisplayActionWin=1
MaxDisplaySize=300
KeepFileNames=1
ShowDisclaim=0
DataPath=C:\RockWin\
FileExtension=RMT

[FileMenu]
MaxLastFiles=4
LastFile1=C:\RockWin\S1.RMT
LastFile2=C:\RockWin\S2.RMT
LastFile3=C:\RockWin\S3.RMT
LastFile4=C:\RockWin\S4.RMT

[TextBrowse]
BrowseFontName=Courier New
BrowseFontSize=10
BrowseFontBold=0
BrowseFontItalic=0

Notes: 

· If this file is deleted, it will be automatically reconstructed the next time the
program is executed but the various settings will default to their original values.
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4.2 Options

Description:

This form is used to define a number of default parameters and settings for the
RockWin program:

General Options
Edit Menu Options

· English menus: If this option is enabled, all menus will appear in English.
Otherwise, they will appear in Greek

· Always show Mohr's Circle when Form Loads: If this option is enabled, then in
the forms where a Mohr's circle is plotted the option will automatically be
activated when the form is loaded even if no data have been loaded. 

· These settings are saved in the RockWin.INI file.

Print Options 
If this option is enabled, then whenever the input data are printed, a three-line header is
prepended with the program version, filename, etc. These settings are saved in the
RockWin.INI file.

Default Settings
This option allows the user to set the form to load at the click of the three quick access
buttons on the toolbar (I, II, III)

Advanced
Create a File Association
Use this option to create an association between the program executable and the
extension of the project files.  Thus, double-clicking on a project file, will invoke the
RockWin program. These settings are saved in the RockWin.INI file.

Debug (Graph)
Use this option to allow showing native graph coordinates in forms where a graph is
generated. These settings are saved in the RockWin.INI file.

Circular Openings (extend)
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Use this option to specify the default x axis extend in the circular opening graphs in
terms of number of radii. These settings are saved in the RockWin.INI file.

4.3 Unit Conversions

Description:

This utility can be used to convert between English and metric units for 4 types of units:

Length
Conversion between inches, feet, centimeters, and meters is supported.

Load
Conversion between lbsF (pounds force), tonsF (short) (short tons force), kN
(kiloNewton), MN (MegaNewton), and kips (thousands of pounds) is supported.

Load Gradient
Conversion between lbsF/in (pounds force per inch), lbsF/ft (pounds force per foot),
kN/m (kiloNewton per meter), and MN/m (MegaNewton per meter) is supported.

Stress
Conversion between psi (pounds per square inch), ksi (thousand pounds per square
inch), psf (pounds per square foot), Pa (Pascals), and MPa (MegaPascals) is
supported.

Stress (Pressure) Gradient
Conversion between psi/in (psi per inch), psi/ft (psi per foot), Pa/m (Pascal per meter),
and MPa/m (MegaPascal per meter) is supported.

Notes:

· 1 Pa = 1 Newton per square meter
· 1 psi = 1 pound per square inch

4.4 File Conversion

Description:

This utility can be used to convert the current file to a different set of units. If the file is
in English units, then it can only be converted to metric and vice versa.

Notes:

· The current file should already be saved before accessing the conversion
option.
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· The current file is then substituted with the converted file.
· A prefix is added to the name of the converted file.
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5 The Help Menu

Use the Help menu option to access various help options, the About Rockwin form, the
Disclaimer form, as well as information regarding the current version of the program.

See Also: 
· About RockWin
· Disclaimer
· Program Updates

5.1 About RockWin

The RockWin program was created and is currently maintained by created by Prof.
Zach Agioutantis, TUC & UKy. 

The contribution of the following individuals is acknowledged:
1. Mr. Kostas Seiradakis, Mineral Resources Engineer, TUC, for the development of

part of the original routines, and 
2. Mr. Thomas Vallas, Mineral Resources Engineer, TUC, for the development of the

surface loading routines

5.2 Disclaimer

This software is provided 'AS IS' without warranty of any kind including express or
implied warranties of merchantability or fitness for a particular purpose. By acceptance
and use of this software, which is conveyed to the user without consideration by the
developers, the user expressly waives any and all claims for damage and/or suits for
personal injury or property damage resulting from any direct, indirect, incidental, special
or consequential damages, or damages for loss of profits, revenue, data or property
use, incurred by the user or any third party, whether in an action in contract or tort, arising
from access to, or use of, this software in whole or in part. 

See also: Program Updates

5.3 Program Updates

No further development or upgrades for this software is planned. However, minor
updates may be issued periodically.  This program is automatically set to remind the
user to check the program web site for an updated version a calendar year after each
revision.   If an update exists, the user may manually download the setup file and install
the new version.  
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5.4 References

Hoek, E. (2007). Practical rock engineering.

5.5 HelpButton

Position the cursor on any item on the form and press F1 for context sensitive
help.
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6 List of Figures
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Figure 6: 
Figure 7: 
Figure 8: 

6.1 Figure 1
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6.2 Figure 2

6.3 Figure 3
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6.4 Figure 4
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6.5 Figure 5
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