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The Utilities Menu
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About BlastWin
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1.1 Overview
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2 The File Menu

Description:

Use the File menu option to access various file management operations such as:

Creating New Files

Opening Existing Files

Saving Files

Saving Files under Different Names  (Save As)

Setting up the Printer

Printing Files

Print Preview

Browsing Text Files

Exiting the Program

2.1 Creating New Files

Description:

Use the New option to erase the existing dataset (if any) from memory and create a
new (blank) dataset.  All related entries are set to their initial values. 

Notes:

The program will prompt you whether to save the current file to disk.

2.2 Opening Existing Files

Description:

Use the open option to load a file (dataset) from the disk into program memory.

To use Open:

Select the Open option from the File menu.  The program displays a listing of
the available files in the current data directory.
Optionally, select a different drive or directory using the mouse or the cursor
control keys.
Select or enter a filename.  

Notes:

If the file extension is omitted, the default extension will be appended. 
If the current dataset is not saved, the program will prompt whether to save
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changes or not before discarding the current dataset.

2.3 Saving Files

Description:

Use the Save option to save an existing file (dataset) to the drive or directory from
which it was originally loaded.  Any changes that were made since the last time the file
was saved will be saved on the disk.  The filename stays the same and the file remains
in memory.

To use Save:

Select the Save option from the File menu.

Notes:

If the file has never been saved using the Save As option, choosing Save
automatically displays the Save As dialogue box, which prompts for a filename
before saving it.

2.4 Saving Files under Different Names  (Save As)

Description:

Use the Save As option to save a file and give it a new name.

To use Save As:

Select the Save As option from the File menu.  The program displays a listing of
the available files in the current data directory.
Optionally, select a different drive or directory. 
Select or enter a filename.

Notes:

If the file exists, the program will prompt whether to overwrite the existing file.
Use Save for a faster save operation.

2.5 Setting Up the Printer

Description:

Use this option to select the Printer to use for printing output and graphics. This printer
becomes the Windows default printer. 

To use this option:

Select the Printer from the drop-down list and click on OK. 
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2.6 Printing Files

Description:

Use the Print option to print the current dataset (file) from program memory to the
default windows printer.  The default printer may be set using the Setting Up the Printer
menu option. 

Notes:

The file is send directly to the printer, without preview. Use the Print Preview
option to preview the file and then send it to the printer. 

2.7 Print Preview

Description:

The user may navigate through the Print Preview Window by using the vertical scroll
bar. 

The text in the window can be send directly to the printer, or it can be copied to the
Windows clipboard for use in other applications.

Notes:

This operation does not send any control characters to the printer. All output is
ASCII text. The text prints in "Courier" or "Courier New" font in size 9. If these
fonts are not available to the printer, then printed text will appear in the default
printer font.
Each printed page is formatted with preset margins as follows:

left margin = 1 inch
top margin = 1 inch
bottom margin = 1 inch
right margin = variable

2.8 Browsing Text Files

Description:

Use the browse option to view a text (ASCII) file in a specified directory.  No editing is
allowed during browsing.

Use the pattern field to specify a file pattern (i.e. *.txt). The file window will be reset to
conform to the specified pattern. The default pattern is *.ALP. More than one patterns
can be applied using “;” as delimiter (e.g. *.txt;*.dxf).

Use the Set Font command button to specify the type and size of font for the displayed
text. These settings are saved in the BlastWin.INI file.

Use the cursor control keys to move within the browse window.
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2.9 Exiting the Program

Description:

Use the Exit option when ready to exit this program and return to the original
environment. The program will prompt you to save the current file to disk, if not already
saved.



Part

III



The Input Menu 11

© 2022 Prof. Z. Agioutantis

3 The Input Menu

Description:

Use the Edit menu option to access various parameter input/edit forms such as:

Project Description

Burden Calculations (this includes a number of options categorized thematically)

Blast Calculations

Vibrations 

3.1 Project Description

Description:

This is an arbitrary 300 character description of the model being generated.  It is a
recommended to make this a fairly detailed description of the specifics of the input file.
This text may be a single line of characters or may contain "carriage return characters".

The user can also set the type of units that will be used in the current project. The
program is designed to use mixed set of units, i.e. either English (i.e. ft, in) or Metric
(m, mm).

Note that calculations performed in many of the forms in this program are unitless, i.e.
they work the same for any unit. 

3.2 Burden Calculations

Description:

Use this menu to access a number of different burden calculation equations. The units
used in each case are the original units applied in each case. Blastwin can current
calculate burden using the following formulations:

Anderson Equation
Ash Equation
Fraenkel Equation
Konya Equation
Langefors Equation
Pearse Equation
Jimeno Equation
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3.3 Blast Calculations

Description:

This option allows the user to calculate several parameters used for blast design. The
burden can be either calculated though any of the burden calculation formulations or
entered by the user. 

Parameters directly depending on burden such as stemming and subdrilling can be
calculated either as a function of blasthole diameter or as a function of burden. 

The program will calculate the optimum blasthole configuration based on the minimum
difference between the desired production value and the actual production value.

3.4 Vibrations

Description:

This menu option allows the user the potential damage of the due to vibrations based
on a number of international specifications.
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4 The Utilities Menu

Settings

Options

Unit Conversions

File Conversion

Clear History Window
This option clears the history (activity) window.

Close/Restore History Window
This option closes or restores the history (activity) window according to the current
window status.

Copy History Window
This option copies the contents of the history window to the clipboard. You can then
paste them to any text handling program for further processing. 

4.1 Settings

Description:

This form is used to define a number of default parameters and settings for the
BlastWin program:

Default Units:
This setting controls the default units for a new or blank project file by configuring the
Units field in the Project Description form. Upon entering and accepting project input
parameters the default setting in the Project Description form can not be changed. 
This setting is saved in the BlastWin.INI file.

Default File Extension for Input Files:
This setting is the default 3-letter extension used in the Open and Save dialog boxes in
the File Menu. This setting is saved in the BlastWin.INI file.

Data Path:
This setting is the default path used in the Open and Save dialog boxes in the File
Menu.  This setting is saved in the BlastWin.INI file.

Show Disclaimer:
This parameter controls whether the disclaimer message will be displayed when
loading the BlastWin program. This setting is saved in the BlastWin.INI file.

Maximize Main Menu Window:
This parameter controls whether the main menu window will be maximized when
loading the BlastWin  program. This setting is saved in the BlastWin.INI file.

Keep Recent Filelist:
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This parameter controls whether the program will keep the four (4) recently accessed
data files (opened or saved) as menu items in the File Menu. This setting is saved in
the BlastWin.INI file.

Reminder of Annual Updates:
This parameter controls whether the program will display a warning that a year has
elapsed since the last update of the program. The update date is internally stored and
it is not related with the install date. Annual updates ensure that any bugs that have
been discovered are fixed regularly. This setting is saved in the BlastWin.INI file.

Display Command History Window:
This parameter controls whether the program will display recently executed commands
(and their resulting actions).  This setting is saved in the BlastWin.INI file.

Maximum Characters in Command History Window:
This parameter sets the maximum number of characters displayed in the command
history window, before it is cleared.  This setting is enabled only if the Display
Command History Window option is enabled.  This setting is saved in the BlastWin.INI
file.

History Font:
This button sets the type and size of font used in the command history window. This
setting is enabled only if the Display Command History Window option is enabled. 
This setting is saved in the BlastWin.INI file.

Enable Toolbar: 
This settings controls whether the program will display a toolbar under the main menu
options or not. The toolbar is not editable. This setting is saved in the BlastWin.INI file.

Short Names in Filelist:
This parameter controls whether the program will display the filenames in the recently
accessed list in a short or long format (i.e. including the whole path).  This setting is
saved in the BlastWin.INI file.

Load Last Input File:
When this setting is enabled, the program will automatically load the most recently
saved datafile (i.e. the top in the recently accessed files). This setting is saved in the 
BlastWin.INI file.

Copy Example Files:
When this setting is enabled, the program will automatically copy all example files from
the "Program Files" directory to the user home directory (i.e. MyDocuments/MyTUC).
This procedure runs upon every program invocation unless disabled. The modified files
will not be overridden, but missing files will be replaced. This setting is saved in the 
BlastWin.INI file.

External ASCII Viewer:
The user can set the application name of an external ASCII viewer for viewing reports
and other ASCII files generated by the program.  The default viewer in NOTEPAD.EXE
supplied with the windows operating system.  Note that prior to Windows2000,
NOTEPAD.EXE could only edit / display files up to 64K.  This setting is saved in the 
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BlastWin.INI file.

4.1.1 BlastWin.INI

Description:

This file is automatically created by the BlastWin program the first time it is executed. It
should reside in the home directory of the BlastWin program, i.e. \BlastWin.  It contains
the following entries (the sequence and parameter values may be different in the actual
file):

[Settings]
DefaultUnits=0
DisplayActionWin=1
MaxDisplaySize=300
KeepFileNames=1
ShowDisclaim=0
DataPath=C:\BlastWin\
FileExtension=RMT

[FileMenu]
MaxLastFiles=4
LastFile1=C:\BlastWin\S1.WBT
LastFile2=C:\BlastWin\S2.WBT
LastFile3=C:\BlastWin\S3.WBT
LastFile4=C:\BlastWin\S4.WBT

[TextBrowse]
BrowseFontName=Courier New
BrowseFontSize=10
BrowseFontBold=0
BrowseFontItalic=0

Notes: 

If this file is deleted, it will be automatically reconstructed the next time the
program is executed but the various settings will default to their original values.

4.2 Options

Description:

This form is used to define a number of default parameters and settings for the
BlastWin program:

Edit Options
English Menus
If this option is enabled program menus and messages will be in English. These
settings are saved in the BlastWin.INI file.

Print Options
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Print Module Version Information
If this option is enabled, then whenever the input data are printed, a three-line header is
prepended with the program version, filename, etc. These settings are saved in the 
BlastWin.INI file.

Solution Options
Show all Blast Design Solutions
If this option is enabled then the program will display all blast design solution instead of
just the optimum. These settings are saved in the BlastWin.INI file.

Warnings
Warning about Burden Calculation Parameters
If this option is enabled, whenever a burden calculation formulation is accessed
through the blast design menu item, a warning will be displayed. These settings are
saved in the BlastWin.INI file.

Advanced
Create a File Association
Use this option to create an association between the program executable and the
extension of the project files.  Thus, double-clicking on a project file, will invoke the
BlastWin program. These settings are saved in the BlastWin.INI file.

Debug
Show Internal Coordinates in Graphs
When this option is enabled the program displays the internal graph coordinates. This
can be used for debugging. These settings are saved in the BlastWin.INI file.

4.3 Unit Conversions

Description:

This utility can be used to convert between English and metric units for 4 types of units:

Pressure
Conversion between psi (pounds per square inch), Pa (Pascals) and MPa
(MegaPascals) is supported.

Length
Conversion between feet, inches, meters and centimeters is supported.

Stress (Pressure) Gradient
Conversion between psi/ft (psi per foot), psi/in (psi per inch), MPa/m (MegaPascal per
meter) and Pa/m (Pascal per meter) is supported.

Load Gradient
Conversion between lbs/ft (pounds per foot), lbs/in (pounds per inch), kN/m
(kiloNewton per meter) and MN/m (MegaNewton per meter) is supported.

Notes:

1 Pa = 1 Newton per square meter



BlastWin Help18

© 2022 Prof. Z. Agioutantis

1 psi = 1 pound per square inch

4.4 File Conversion

Description:

This utility can be used to convert the current file to a different set of units. If the file is
in English units, then it can only be converted to metric and vice versa.

Notes:

The current file should already be saved before accessing the conversion
option.
The current file is then substituted with the converted file.
A prefix is added to the name of the converted file.
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5 The Help Menu

Use the Help menu option to access various help options, the Disclaimer screen, as
well as information regarding the current version of the program.

Disclaimer:

The authors declare that there are no warranties, expressed or implied, which apply to
the software contained herein.  By acceptance and use of said software, which is
conveyed to the user without consideration by the authors, the user hereof expressly
waives any and all claims for damage and/or suits for or by reason of personal injury, or
property damage, including special, consequential or other similar damages arising
out of or in any way connected with the use of the software contained herein.

See Also: About BlastWin

5.1 About BlastWin

The BlastWin program was originally created by Thomas Vallas and Professor Zach
Agioutantis at the Technical University of Crete.

5.2 References

Jimeno, C.L., Jimeno E.L. and Carcedo, F.J.A., Drilling and blasting of rocks,
Balkema, Rotterdam (1995).

5.3 HelpButton

Position the cursor on any item on the form and press F1 for context sensitive
help.
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